Настройка iptv на роутере mikrotik (multicast)

Инструкция по настройке IPTV от Ростелеком роутера Mikrotik

На роутере Mikrotik настройка IPTV Ростелеком на основе pppoe соединения выполняется следующим образом:

  1. Установка макета Multicast. Он загружается с официального сайта и устанавливается в роутер. Для тех, кто не знает, как это делать, в Интернете предусмотрены соответствующие инструкции.
  2. Настройка соединения. Осуществляется через Winbox. Для оперативности смены конфигурации можно использовать Quick Set. Далее нужно открыть вкладку Interfaces, а для избегания путаницы все параметры желательно откомментировать. 1-й порт ether1 – WAN, 2-й — ether2 переназывается в ether2-master, пометка LAN. Порты ether3 и ether4 остаются в том же виде. К 5 порту подключается приставка для IPTV. Ether5 переименовывается в ether5-master, пометка IPTV.
  3. Удаление erther5-master. Необходимо перейти в опцию Bridge (Мост), где открыть Ports и удалить там erther5-master (объект выделяется и нажимается клавиша «минус»).
  4. Прописывание Master Port. Следует вернуться в Interfaces и 2 раза кликнуть по erther5-master. В новом окне прописывается Master Port: ether1 для IPTV. Так пробрасывается порт ether1 на ether5.
  5. Настройка доступа для активации IPTV Ростелеком. Нужно перейти в функцию Routing, где выбрать IGMP Proxy. В новом окне выбирается опция Settings и отмечается Quick Leave (оперативное переподключение). Для настройки IPTV Ростелеком на роутере Mikrotik нужно прописать прохождение пакетов программы на портах. Добавляются интерфейсы Proxy для ether1 и ether5-master с помощью плюсика синего цвета.
  6. Прописывание условий для файервола. Необходимо открыть вкладку IP, перейти на Firewall и добавить два правила: разрешение установки пакетов igmp и проброс udp для IPTV.
  7. По выполнении перечисленных процедур следует открыть вкладку System, перезагрузить роутер Reboot и подключить IPTV к 5 порту. Если у оператора реализована схема через VLAN, то на порте, к которому присоединен шнур поставщика Интернет-соединения, необходимо сформировать саб-интерфейс с vlan-ом для IPTV. Его номер может предоставить техподдержка провайдера.
  8. После этого, нужно зайти в ->, где нажать для формирования нового соединения и указать номер VLAN ID, тот который предоставит провайдер. Затем создается новый бридж, куда добавляются созданный VLAN и порт, к которому присоединена приставка. Порт удаляется из старого бриджа, если он уже задействован. При неполадках в параметрах бриджа прописывается STP в none.

Установка IPTV

Настройка
телевещания на роутере Микротик
начинается с установки новой операционной
системы с подходящей версией.

Подробнее:

  1. Нужно скачать RouterOS
    и установить программу на компьютер.
    Это самая актуальная версия ОС для
    устройств Микротик.
  2. Откройте настройки устройства с помощью
    утилиты WinBox.
  3. Найдите кнопку «Files»,
    перенесите туда файл из пакета с
    названием «multicast».
  4. Откройте раздел «System»,
    найдите пункт «Reboot» или
    же введите в командную строку следующие
    символы: «system reboot». Это перезапустит
    роутер для того, чтобы изменения вступили
    в силу.
  5. Откройте пункт «System», в
    контекстном меню найдите раздел
    «Packages». Если в нем появился
    файл из пакета, то настройка мультикаста
    завершена.

Для просмотра
телевидения этого мало, поэтому настройка
Mikrotik IPTV
продолжается.

Настройка IGMP Proxy

Настройка
IGMP на Mikrotik
IPTV связана с указанием
данных подсетей провайдеров, которые
нужны для приема сигнала. Если информации
об этом у пользователя нет, то приходится
перебирать «стандартные» варианты.

Подробнее:

  1. Через утилиту откройте раздел «Routing»,
    затем перейдите в «IGMP
    Proxy».
  2. В открывшемся окне найдите строку
    «Interface», укажите в нем
    номер порта, куда подключен интернет.
  3. В разделе «Alternative Subnets»
    напишите номер подсети провайдеров,
    добавьте галочку в разделе «Upstream».

В качестве «стандартных» вариантов
можно использовать следующие:

  • 10.0.0.0/8;
  • 192.168.0.0/16;
  • 172.16.0.0/12.
  1. Остальные параметры оставьте по
    умолчанию, нажмите кнопку «ОК».
  2. Кликнете по изображению «+» для добавления
    портов ТВ.
  3. В поле «Interface» укажите
    порт роутера, который соединен с
    телевизором.
  4. Галочка не ставится, подсеть не
    прописывается. Нажмите кнопку «Ок».
  5. В окне «IGMP Proxy»
    найдите кнопку «Settings»,
    нажмите на нее. Поставьте галочку в
    строке «Quick Leave»,
    кликните «ОК».

Настройка
прокси на этом завершена. При соблюдении
всех указаний роутер будет принимать
сигнал и передавать его на ТВ.

Настройка Firewall

На устройстве
Микротик настройка IPTV
осложняется встроенной защитой, которая
может не пропустить сигнал телевещания.
Поэтому дополнительно изменяются
параметры фаервола.

Подробнее:

  • В главном меню утилиты найдите раздел
    «New Terminal».
  • Введите поочередно 3 строки программного
    кода, где вместо «*название порта входа*»
    прописывается порт, указанный в строке
    «Interface» на втором шаге
    предыдущей инструкции:

/ip firewall filter add action=accept chain=input
comment=»Allow IGMP» disabled=no in-interface=*название
порта входа*
protocol=igmp

/ip firewall filter add action=accept chain=input
comment=»IPTV UDP incoming» disabled=no dst-port=1234
in-interface=*название порта
входа* protocol=udp

/ip firewall filter add action=accept
chain=forward comment=»IPTV UDP forwarding» disabled=no
dst-port=1234 protocol=udp

  • После выполнения программного кода
    новые правила для фаервола добавятся
    в меню «Firewall», который
    находится на вкладке «IP».
  • Перенесите их в самый вверх, чтобы их
    приоритет стал выше запрещающих строк.

После этого
можно просматривать телеканалы. Остальные
настройки понадобятся тем, кто подключает
роутер и телевизор по Wi-Fi.

Настройка Wi-Fi

Для настройки
соединения Mikrotik Hap
Lite IPTV и
телевизора по Wi-Fi
требуется выполнить инструкцию:

  1. В главном меню выберите раздел «Wireless».
  2. В открывшемся окне активируйте вкладку
    «Interface».
  3. Дважды кликните по имеющемуся подключению.
  4. На вкладке «Wireless» нажмите
    на кнопку «Advanced Mode».
  5. Установите режиме «Enable»
    в строке «WMM Support».
  6. Выберите «Full» в
    списке «Multicast Helper».
  7. Нажмите кнопку «ОК».

Сброс настроек роутера

Сбросить
настройки роутера Микротик IPTV
можно несколькими способами:

  • Через кнопку Reset на задней
    стороне устройства.
  • Нажатием на кнопку в специальном
    отверстии в плате роутера.
  • С помощью джампера.

Первый
вариант самый простой и доступен
пользователям большинства роутеров.

Через кнопку Reset

Для сброса
настроек до заводских параметров,
например на моделях линейки Hap
Lite, выполните инструкцию:

  1. Выключите блок питания.
  2. Найдите кнопку «Reset» на
    обратной стороне устройства, зажмите
    ее и не отпускайте.
  3. Запустите роутер, подключив блок
    питания.
  4. Дождитесь, пока не замигает лампа «ACT»,
    затем сразу же отпустите кнопку «Reset».

Не дожидайтесь,
пока лампочка перестанет мигать. Если
жать слишком долго, то начнется процедура
переустановки операционной системы.

Через отверстие в плате

Современные
устройства с платой «RouterBOARD»
имеют отверстие для доступа к кнопке
сброса настроек, которая обозначена
двумя полумесяцами.

Подробнее:

  1. Отключите блок питания.
  2. Переверните роутер для поиска отверстия.
    Если его нет, то придется открыть крышку
    устройства.
  3. Замкните контакты полумесяцев отверткой
    и не убирайте ее до момента сброса
    настроек.
  4. Подключите блок питания.
  5. Уберите отвертку от контактов, когда
    замигает лампа «ACT».

Подобный
вариант восстановления заводских
параметров сложнее предыдущего, поэтому
используется только при отсутствии
иных способов.

Сброс джампером

Инструкция
для сброса параметров джамперов актуальна
только для старых моделей роутеров.

Подробнее:

  1. Отключите блок питания.
  2. Найдите джампер с надписью «Soft
    Reset». Если его нет, то
    придется открыть крышку роутера.
  3. Зажмите две части джампера между собой
    отверткой или перемычкой. Не убирайте
    ее, пока не произойдет сброс.
  4. Подключите блок.
  5. Дождитесь сигнала о восстановлении
    заводских параметров и уберите перемычку.

Если не
убрать перемычку, то каждый новый запуск
будет сопровождаться сбросом настроек.

Ссылка на основную публикацию